题目链接:[ HDU - 1159 ]

A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = <x1, x2, ..., xm> another sequence Z = <z1, z2, ..., zk> is a subsequence of X if there exists a strictly increasing sequence <i1, i2, ..., ik> of indices of X such that for all j = 1,2,...,k, xij = zj. For example, Z = <a, b, f, c> is a subsequence of X = <a, b, c, f, b, c> with index sequence <1, 2, 4, 6>. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y.
The program input is from a text file. Each data set in the file contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct. For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line.

Sample Input

abcfbc abfcab
programming contest 
abcd mnp

Sample Output

4
2
0

题解

输入两个串$s,t$, 设$dp(i,j)$表示: $s$的左边$i$个字符形成的子串,与$t$左边的$j$个字符形成的子串的最长公共子序列的长度(i,j从0 开始算)
$dp(i,j)$ 就是本题的“状态”
假定$ len1 = strlen(s)$,$len2 = strlen(t)$
那么题目就是要求 $dp[len1,len2] $

显然:
$dp(n,0) = 0 ( n= 0…len1)$
$dp(0,n) = 0 ( n= 0…len2)$

递推公式:

if ( s[i-1] == t[j-1] )    //s的最左边字符是s1[0]   
&emsp;dp(i,j) = dp(i-1,j-1) + 1;  
else  
&emsp;dp(i,j) = max(dp(i,j-1), dp(i-1,j) );

时间复杂度$O(m \times n)$, $m,n$是两个字串长度

#include<iostream>
#include<string>
#include<cstdio>
#include<cstring>
#include<queue>
#include<map>
#include<set>
#include<algorithm>
#include<cmath>
#include<cstdlib>
using namespace std;

char s[1005], t[1005];
int dp[1010][1010];

int main(void)
{
    while(~scanf("%s%s" ,s ,t)){
        int len1 = strlen(s);
        int len2 = strlen(t);
        for (int i = 0; i <= len1; i++)
            dp[i][0] = 0;
        for (int i = 0; i <= len2; i++)
            dp[0][i] = 0;

        for (int i = 0; i < len1; i++){
            for (int j = 0; j < len2; j++){
                if(s[i]==t[j])
                    dp[i + 1][j + 1] = dp[i][j] + 1;
                else
                    dp[i + 1][j + 1] = max(dp[i][j + 1], dp[i + 1][j]);
            }
        }

        cout << dp[len1][len2] << endl;
    }

    return 0;
}