题目链接:[ HDU - 1213 ]

Today is Ignatius' birthday. He invites a lot of friends. Now it's dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and all the friends do not want to stay with strangers.

One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table.
For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least.

Input

The input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the number of friends, the friends are marked from 1 to N. Then M lines follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases.

Output

For each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks.

Sample Input

2
5 3
1 2
2 3
4 5

5 1
2 5

Sample Output

2
4

题解

#include<iostream>
using namespace std;

int par[1010];
int ran[1010];

void init(int n)
{
    for(int i=1; i<=n; i++){
        par[i]=i;
        ran[i]=0;
    }
}

int find(int x)
{
    if(par[x]==x)
        return x;
    else
        return par[x]=find(par[x]);
}

void unite(int x, int y)
{
    x=find(x);
    y=find(y);
    if(x==y)
        return;

    if(ran[x]<ran[y]){
        par[x]=y;
    }else{
        par[y]=x;
        if(ran[x]==ran[y])
            ran[x]++;
    }
}

int main(void)
{
    int t, m, n, a, b;
    cin >> t;
    while(t--){
        scanf("%d%d", &n, &m);
        init(n);
        for(int i=0; i<m; i++){
            scanf("%d%d", &a, &b);
            if(a<b)
                swap(a, b);
            unite(a, b);
        }
        int sum=0;
        for(int i=1; i<=n; i++){
            if(par[i]==i)
                sum++;
        }
        printf("%d\n", sum);
        getchar();
    }
}